Which browsers are compatible with the application?

BenchSci's web-based application works on most modern browsers

BenchSci supports ECMAScript 6 (ES6 2015)

BrowserSupported browser versions start at
Google Chrome (recommended)Chrome 58 (2017)
Microsoft EdgeEdge 14 (2016)
Mozilla FirefoxFirefox 54 (2017)
SafariSafari 10 (2016)

If you ever experience strange behaviour, try opening an incognito/private browsing window or clearing your cache.

Support for Internet Explorer (IE11)

Microsoft has begun scaling back support on Internet Explorer as they are retiring the browser in June 2022. As a result, to ensure a secure and optimal experience for all our users, BenchSci will no longer support Internet Explorer starting August 17, 2021.

Users will need to use one of the supported browsers to log into BenchSci after August 17, 2021. Users that try to log in using Internet Explorer will see a message directing them to try in one of the supported browsers listed above.

If you have any questions, please contact us.